FAI 5,7 Debian Stretch LVM Bug

Leider ist bei FAI 5,7 auch wieder der LVM Bug vorhanden wenn man einen bereits installierten Server mit LVM neu installieren will.

Bricht die Installation mit error 710 ab

Diesmal braucht man allerdings nicht allzu viel Patchen

sed -i 's/use_lvmetad = 1/use_lvmetad = 0/' /srv/fai/nfsroot/etc/lvm/lvm.conf

Das ganze als nfsroot-hooks macht das Leben einfacher

nano /etc/fai/nfsroot-hooks/10-patch-lvm-config
#!/bin/bash 

# use_lvmetad für die Installation Umgebung ausschalten
echo "PATCHING /srv/fai/nfsroot/etc/lvm/lvm.conf" 
echo "############################################"
sed -i 's/use_lvmetad = 1/use_lvmetad = 0/' /srv/fai/nfsroot/etc/lvm/lvm.conf

Das ganze noch ausführbar machen

chmod 755 /etc/fai/nfsroot-hooks/10-patch-lvm-config

Und beim nächsten fai-setup wird der Patch dann automatisch gemacht

Getagged mit: ,

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.

*